Click or drag to resize

GH_DocumentExpandSelection Method

Grow or shift the selection set based on source and recipient links

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void ExpandSelection(
	bool Upstream = true,
	bool Downstream = true,
	bool GrowSelection = true
)

Parameters

Upstream (Optional)
Type: SystemBoolean
If True, the selection will grow/shift upstream
Downstream (Optional)
Type: SystemBoolean
If True, the selection will grow/shift downstream
GrowSelection (Optional)
Type: SystemBoolean
If True, the current selection set is retained. If False, the current selection set is discarded
See Also