Description:

Imports a material file (.RMTL) and assigns the imported material to one or more layers.

Syntax:
public static bool ImportMaterialAndAssignToLayers(
RhinoDoc doc,
string file,
IEnumerable<int> layer_indices
)
Parameters:
  • doc
  • Type: RhinoDoc
  • The document to attach the imported material to and which also contains the layers.
  • file
  • Type: string
  • The full path to the RMTL file to be imported.
  • layer_indices
  • Type: IEnumerable<int>
  • An array of indices of the layers to assign the material to.
Returns:
Type: bool
True if successful, else false.
Available since:
8.0

/
/
/
ImportMaterialAndAssignToLayers

ImportMaterialAndAssignToLayers method

Class:  Rhino.Render.RenderMaterial

Nothing found