Description:

Call this function to receive the simulation for a RenderMaterial used by the display and other rendering engines.

Syntax:
public virtual Material SimulateMaterial(
bool isForDataOnly
)
virtual
deprecated in 7.0
obsolete: Incorrect spelling - use ToMaterial instead, and don't override this virtual function
Parameters:
  • isForDataOnly
  • Type: bool
  • Called when only asking for a hash - don't write any textures to the disk - just provide the filenames they will get.
Returns:
Type: Material
The simulation of the render material
Available since:
6.0

Description:

Override this function to provide a Rhino.DocObjects.Material definition for this material to be used by other rendering engines including the display.

Syntax:
public virtual void SimulateMaterial(
ref Material simulation,
bool isForDataOnly
)
virtual
deprecated in 8.0
obsolete: ToMaterial with TextureGeneration instead, and don't override this virtual function
Parameters:
  • simulation
  • Type: DocObjects.Material
  • Set the properties of the input basic material to provide the simulation for this material.
  • isForDataOnly
  • Type: bool
  • Called when only asking for a hash - don't write any textures to the disk - just provide the filenames they will get.
Returns:
Type: void
Available since:
5.1

Description:

Override this function to provide a Rhino.DocObjects.Material definition for this material to be used by other rendering engines including the display.

Syntax:
public virtual void SimulateMaterial(
ref Material simulation,
TextureGeneration tg
)
virtual
Parameters:
  • simulation
  • Type: DocObjects.Material
  • Set the properties of the input basic material to provide the simulation for this material.
Returns:
Type: void
Available since:
7.0

SimulateMaterial method

Class:  Rhino.Render.RenderMaterial

Nothing found