Description:

Controls display of the curve snap tangent bar icon.

Syntax:
public void EnableCurveSnapTangentBar(
bool drawTangentBarAtSnapPoint,
bool drawEndPoints
)
Parameters:
  • drawTangentBarAtSnapPoint
  • Type: bool
  • True to draw a tangent bar icon whenever GetPoint snaps to a curve.
  • drawEndPoints
  • Type: bool
  • True to draw points at the end of the tangent bar.
Returns:
Type: void
Remarks:
The tangent bar is drawn by GetPoint::DynamicDraw. If you override GetPoint::DynamicDraw, then you must call the base class function.
Available since:
5.0

/
/
/
EnableCurveSnapTangentBar

EnableCurveSnapTangentBar method

Class:  Rhino.Input.Custom.GetPoint

Nothing found