Description:

Adds points to the list of osnap points.

Syntax:
public int AddSnapPoints(
Point3d[] points
)
Parameters:
  • points
  • Type: Point3d[]
  • An array of points to snap onto.
Returns:
Type: int
Total number of snap points.
Remarks:
When point osnap is enabled, GetPoint will snap to points in the Rhino model. If you want the user to be able to snap to additional points, then use GetPoint::AddSnapPoints to specify the locations of these additional points.
Available since:
5.0

AddSnapPoints method

Class:  Rhino.Input.Custom.GetPoint

Nothing found