Description:

Use to determine if point was on a surface. If the point was on a surface, then the (u,v) are the surface parameters for the point. The point returned by Point() is the same as surface.PointAt(u,v).

Syntax:
public Surface PointOnSurface(
out double u,
out double v
)
Parameters:
  • u
  • Type: double
  • If the point was on a surface, then the u parameter.
  • v
  • Type: double
  • If the point was on a surface, then the v parameter.
Returns:
Type: Surface
The surface or None if the point was not on a surface.
Available since:
6.0

PointOnSurface method

Class:  Rhino.Input.Custom.GetPoint

Nothing found