Click or drag to resize

GH_PersistentGeometryParamT Methods

The GH_PersistentGeometryParamT generic type exposes the following members.

Methods
  NameDescription
Public methodClearData (Overrides GH_ParamTClearData.)
Protected methodConversionCallback (Overrides GH_ParamTConversionCallback(Object, T).)
Protected methodEraseGeometryCaches
Public methodExpireSolution (Overrides GH_ActiveObjectExpireSolution(Boolean).)
Protected methodOnVolatileDataCollected
This override removes all instances that fail to load their geometry.
(Overrides GH_ParamTOnVolatileDataCollected.)
Public methodRegisterRemoteIDs (Overrides GH_ActiveObjectRegisterRemoteIDs(GH_GuidTable).)
Protected methodRegisterRemoteIdsDespiteSources
Call this method if you wish to register remote ids in the volatile data despite having one or more sources. You should only need to do this if you converted non-referenced data into volatile referenced data.
Top
See Also