Description:

Draws corner widgets of a world aligned bounding box.

Syntax:
public void DrawBoxCorners(
BoundingBox box,
Color color,
double size,
int thickness
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • Color to draw with.
  • size
  • Type: double
  • Size (in model units) of the corner widgets.
  • thickness
  • Type: int
  • Thickness (in pixels) of the corner widgets.
Returns:
Type: void
Available since:
5.0

Description:

Draws corner widgets of a world aligned bounding box.

Syntax:
public void DrawBoxCorners(
BoundingBox box,
Color color,
double size
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • Color to draw with.
  • size
  • Type: double
  • Size (in model units) of the corner widgets.
Returns:
Type: void
Available since:
5.0

Description:

Draws corner widgets of a world aligned bounding box. Widget size will be 5% of the Box diagonal.

Syntax:
public void DrawBoxCorners(
BoundingBox box,
Color color
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • Color to draw with.
Returns:
Type: void
Available since:
5.0

DrawBoxCorners method

Class:  Rhino.Display.DisplayPipeline

Nothing found