Description:

Draw a typical Rhino Curvature Graph.

Syntax:
public void DrawCurvatureGraph(
Curve curve,
Color color,
int hairScale,
int hairDensity,
int sampleDensity
)
Parameters:
  • curve
  • Type: Curve
  • Base curve for curvature graph.
  • color
  • Type: System.Drawing.Color
  • Color of curvature graph.
  • hairScale
  • Type: int
  • 100 = True length, > 100 magnified, < 100 shortened.
  • hairDensity
  • Type: int
  • >= 0 larger numbers = more hairs (good default is 1).
  • sampleDensity
  • Type: int
  • Between 1 and 10. Higher numbers draw smoother outer curves. (good default is 2).
Returns:
Type: void
Available since:
5.0

Description:

Draw a typical Rhino Curvature Graph.

Syntax:
public void DrawCurvatureGraph(
Curve curve,
Color color,
int hairScale
)
Parameters:
  • curve
  • Type: Curve
  • Base curve for curvature graph.
  • color
  • Type: System.Drawing.Color
  • Color of curvature graph.
  • hairScale
  • Type: int
  • 100 = True length, > 100 magnified, < 100 shortened.
Returns:
Type: void
Available since:
5.0

Description:

Draw a typical Rhino Curvature Graph.

Syntax:
public void DrawCurvatureGraph(
Curve curve,
Color color
)
Parameters:
  • curve
  • Type: Curve
  • Base curve for curvature graph.
  • color
  • Type: System.Drawing.Color
  • Color of curvature graph.
Returns:
Type: void
Available since:
5.0

DrawCurvatureGraph method

Class:  Rhino.Display.DisplayPipeline

Nothing found