/
/
DisplayPipeline

DisplayPipeline class

The display pipeline calls events during specific phases of drawing During the drawing of a single frame the events are called in the following order. [Begin Drawing of a Frame]
  • CalculateBoundingBox
  • CalculateClippingPanes
  • SetupFrustum
  • SetupLighting
  • InitializeFrameBuffer
  • DrawBackground
  • If this is a layout and detail objects exist the channels are called in the same order for each detail object (drawn as a nested viewport)
  • PreDrawObjects
  • For Each Visible Non Highlighted Object
    • SetupObjectDisplayAttributes
    • PreDrawObject
    • DrawObject
    • PostDrawObject
  • PostDrawObjects - depth writing/testing on
  • DrawForeGround - depth writing/testing off
  • For Each Visible Highlighted Object
    • SetupObjectDisplayAttributes
    • PreDrawObject
    • DrawObject
    • PostDrawObject
  • PostProcessFrameBuffer (If a delegate exists that requires this)
  • DrawOverlay (if Rhino is in a feedback mode)
[End of Drawing of a Frame] NOTE: There may be multiple DrawObject calls for a single object. An example of when this could happen would be with a shaded sphere. The shaded mesh is first drawn and these channels would be processed; then at a later time the isocurves for the sphere would be drawn.

Derived Classes:

Namespace: Rhino.Display
DisplayPipeline: references

Nothing found