Description:

Draws a text dot in screen coordinates.

Syntax:
public void DrawDot(
float screenX,
float screenY,
string text,
Color dotColor,
Color textColor
)
Parameters:
  • screenX
  • Type: float
  • X coordinate (in pixels) of dot center.
  • screenY
  • Type: float
  • Y coordinate (in pixels) of dot center.
  • text
  • Type: string
  • Text content of dot.
  • dotColor
  • Type: System.Drawing.Color
  • Dot background color.
  • textColor
  • Type: System.Drawing.Color
  • Dot foreground color.
Returns:
Type: void
Available since:
6.0

Description:

Draws a text dot in screen coordinates.

Syntax:
public void DrawDot(
float screenX,
float screenY,
string text
)
Parameters:
  • screenX
  • Type: float
  • X coordinate (in pixels) of dot center.
  • screenY
  • Type: float
  • Y coordinate (in pixels) of dot center.
  • text
  • Type: string
  • Text content of dot.
Returns:
Type: void
Available since:
6.0

Description:

Draw a text dot in world coordinates.

Syntax:
public void DrawDot(
Point3d worldPosition,
string text,
Color dotColor,
Color textColor
)
Parameters:
  • worldPosition
  • Type: Point3d
  • Location of dot in world coordinates.
  • text
  • Type: string
  • Text content of dot.
  • dotColor
  • Type: System.Drawing.Color
  • Dot background color.
  • textColor
  • Type: System.Drawing.Color
  • Dot foreground color.
Returns:
Type: void
Available since:
5.0

Description:

Draws a text dot in world coordinates.

Syntax:
public void DrawDot(
Point3d worldPosition,
string text
)
Parameters:
  • worldPosition
  • Type: Point3d
  • Location of dot in world coordinates.
  • text
  • Type: string
  • Text content of dot.
Returns:
Type: void
Available since:
5.0

Description:

Draw a text dot as defined by the text dot class

Syntax:
public void DrawDot(
TextDot dot,
Color fillColor,
Color textColor,
Color borderColor
)
Returns:
Type: void
Available since:
6.0

Nothing found