Description:
Draws the viewport as seen from the left and the right eye viewports and returns the result as OpenGL texture handles.
Syntax:
public bool DrawStereoFrameBuffer(
ViewportInfo viewportLeft,
ViewportInfo viewportRight,
out uint handleLeft,
out uint handleRight
)
ViewportInfo viewportLeft,
ViewportInfo viewportRight,
out uint handleLeft,
out uint handleRight
)
Parameters:
- viewportLeft
- Type: DocObjects.ViewportInfo
- The viewport representing the left eye location and look direction.
- viewportRight
- Type: DocObjects.ViewportInfo
- The viewport representing the right eye location and look direction.
- handleLeft
- Type: uint
- Will contain the OpenGL texture handle which references the left output color buffer.
- handleRight
- Type: uint
- Will contain the OpenGL texture handle which references the right output color buffer.
Returns:
Type: bool
True if drawing succeeded, False otherwise.
Available since:
6.8