Description:

Draws a set of connected lines (polyline) with specified pattern.

Syntax:
public void DrawPatternedPolyline(
IEnumerable<Point3d> points,
Color color,
int pattern,
int thickness,
bool close
)
Parameters:
  • points
  • Type: System.Collections.Generic.IEnumerable<Point3d>
  • End points of each line segment.
  • color
  • Type: System.Drawing.Color
  • Color of polyline.
  • pattern
  • Type: int
  • Pattern to use for the line (like 0x00001111 for dotted).
  • thickness
  • Type: int
  • Thickness (in pixels) of lines.
  • close
  • Type: bool
  • Draw a line between the first and last points.
Returns:
Type: void
Available since:
6.0

/
/
/
DrawPatternedPolyline

DrawPatternedPolyline method

Class:  Rhino.Display.DisplayPipeline

Nothing found