Description:

Determines screen rectangle that would be drawn to using the Draw2dText(..) function with the same parameters.

Syntax:
public Rectangle Measure2dText(
string text,
Point2d definitionPoint,
bool middleJustified,
double rotationRadians,
int height,
string fontFace
)
Parameters:
  • text
  • Type: string
  • text to measure.
  • definitionPoint
  • Type: Point2d
  • either lower-left or middle of text.
  • middleJustified
  • Type: bool
  • true=middle justified. false=lower-left justified.
  • rotationRadians
  • Type: double
  • text rotation in radians
  • height
  • Type: int
  • height in pixels (good default is 12)
  • fontFace
  • Type: string
  • font name (good default is "Arial")
Returns:
Type: Rectangle
rectangle in the viewport's screen coordinates on success.
Available since:
5.10

Measure2dText method

Class:  Rhino.Display.DisplayPipeline

Nothing found