menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Draws a single line with specified pattern.
Syntax:
public
void
DrawPatternedLine(
Line
line
,
Color
color
,
int
pattern
,
int
thickness
)
Parameters:
line
Type:
Line
Line to draw.
color
Type:
System.Drawing.Color
Color of line.
pattern
Type:
int
Pattern of the line (like 0x00001111 for dotted line).
thickness
Type:
int
Thickness (in pixels) of lines.
Returns:
Type:
void
Available since:
6.0
Description:
Draws a single line with specified pattern.
Syntax:
public
void
DrawPatternedLine(
Point3d
from
,
Point3d
to
,
Color
color
,
int
pattern
,
int
thickness
)
Parameters:
from
Type:
Point3d
Line start point.
to
Type:
Point3d
Line end point.
color
Type:
System.Drawing.Color
Color of line.
pattern
Type:
int
Pattern of the line (like 0x00001111 for dotted line).
thickness
Type:
int
Thickness (in pixels) of lines.
Returns:
Type:
void
Available since:
6.0
home
/
Rhino.Display
/
DisplayPipeline
/
DrawPatternedLine
DrawPatternedLine method
Class:
Rhino.Display.DisplayPipeline
Nothing found