menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Syntax:
public
void
DrawGradientHatch(
Hatch
hatch
,
IEnumerable<ColorStop>
stops
,
Point3d
point1
,
Point3d
point2
,
bool
linearGradient
,
float
repeat
,
DisplayPen
boundary
,
Color
backgroundFillColor
)
Returns:
Type:
void
Available since:
8.0
Description:
Syntax:
public
void
DrawGradientHatch(
Hatch
hatch
,
IEnumerable<ColorStop>
stops
,
Point3d
point1
,
Point3d
point2
,
bool
linearGradient
,
float
repeat
,
float
boundaryThickness
,
Color
boundaryColor
)
Returns:
Type:
void
Available since:
7.0
Description:
Draw a two point gradient filled hatch
Syntax:
public
void
DrawGradientHatch(
Hatch
hatch
,
Color
color1
,
Color
color2
,
Point3d
point1
,
Point3d
point2
,
bool
linearGradient
,
float
boundaryThickness
,
Color
boundaryColor
)
Returns:
Type:
void
Available since:
7.0
home
/
Rhino.Display
/
DisplayPipeline
/
DrawGradientHatch
DrawGradientHatch method
Class:
Rhino.Display.DisplayPipeline
Nothing found