Description:

Draws a filled, convex polygon from a collection of points.

Syntax:
public void DrawPolygon(
IEnumerable<Point3d> points,
Color color,
bool filled
)
Parameters:
  • points
  • Type: System.Collections.Generic.IEnumerable<Point3d>
  • Collection of world coordinate points that are connected by lines to form a closed shape. Collection must contain at least 3 points.
  • color
  • Type: System.Drawing.Color
  • Color to draw with.
  • filled
  • Type: bool
  • True if the closed area should be filled with color. False if you want to draw just the border of the closed shape.
Returns:
Type: void
Available since:
5.0

DrawPolygon method

Class:  Rhino.Display.DisplayPipeline

Nothing found