Description:

Draws all the wireframe curves os a SubD object using different pens

Syntax:
public void DrawSubDWires(
SubD subd,
DisplayPen boundaryPen,
DisplayPen smoothInteriorPen,
DisplayPen creasePen,
DisplayPen nonmanifoldPen
)
Parameters:
  • subd
  • Type: SubD
  • SubD to draw
  • boundaryPen
  • Type: DisplayPen
  • Pen to use for boundary wires. If null, no boundary wires will be drawn
  • smoothInteriorPen
  • Type: DisplayPen
  • Pen to use for smooth interior wires. If null, no smooth interior wires will be drawn
  • creasePen
  • Type: DisplayPen
  • Pen to use for crease wires. If null, no crease wires will be drawn
  • nonmanifoldPen
  • Type: DisplayPen
  • Pen to use for non-manifold wires. If null, no non-manifold wires will be drawn
Returns:
Type: void

Description:

Draws all the wireframe curves of a SubD object

Syntax:
public void DrawSubDWires(
SubD subd,
Color color,
float thickness
)
Parameters:
  • subd
  • Type: SubD
  • SubD to draw
  • color
  • Type: System.Drawing.Color
  • wire color
  • thickness
  • Type: float
  • wire thickness
Returns:
Type: void
Available since:
7.0

DrawSubDWires method

Class:  Rhino.Display.DisplayPipeline

Nothing found