Description:

Adds geometry that is not further specified. This is meant, for example, to handle addition of sets of different geometrical entities.

Syntax:
public Guid Add(
GeometryBase geometry,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • geometry
  • Type: GeometryBase
  • The base geometry. This cannot be null.
  • history
  • Type: HistoryRecord
  • The history information that will be saved.
  • reference
  • Type: bool
  • If reference is true, object will not be saved in the 3dm file.
Returns:
Type: Guid
The new object ID on success.
Available since:
6.0

Description:

Adds geometry that is not further specified. This is meant, for example, to handle addition of sets of different geometrical entities.

Syntax:
public Guid Add(
GeometryBase geometry,
ObjectAttributes attributes
)
Parameters:
  • geometry
  • Type: GeometryBase
  • The base geometry. This cannot be null.
Returns:
Type: Guid
The new object ID on success.
Available since:
5.0

Description:

Adds geometry that is not further specified. This is meant, for example, to handle addition of sets of different geometrical entities.

Syntax:
public Guid Add(
GeometryBase geometry
)
Parameters:
  • geometry
  • Type: GeometryBase
  • The base geometry. This cannot be null.
Returns:
Type: Guid
The new object ID on success.
Available since:
5.0

Nothing found