Description:

Modifies an object's attributes. Cannot be used to change object id.

Syntax:
public bool ModifyAttributes(
ObjRef objref,
ObjectAttributes newAttributes,
bool quiet
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to object to modify.
  • quiet
  • Type: bool
  • if true, then warning message boxes are disabled.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Modifies an object's attributes. Cannot be used to change object id.

Syntax:
public bool ModifyAttributes(
RhinoObject obj,
ObjectAttributes newAttributes,
bool quiet
)
Parameters:
  • quiet
  • Type: bool
  • if true, then warning message boxes are disabled.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Modifies an object's attributes. Cannot be used to change object id.

Syntax:
public bool ModifyAttributes(
Guid objectId,
ObjectAttributes newAttributes,
bool quiet
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to modify.
  • quiet
  • Type: bool
  • if true, then warning message boxes are disabled.
Returns:
Type: bool
True if successful.
Available since:
5.0

ModifyAttributes method

Class:  Rhino.DocObjects.Tables.ObjectTable

Nothing found