Description:

Adds an instance object to the document.

Syntax:
public Guid AddInstanceObject(
int instanceDefinitionIndex,
Transform instanceXform,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • instanceDefinitionIndex
  • Type: int
  • The index of the instance definition.
  • instanceXform
  • Type: Transform
  • The instance transformation.
  • history
  • Type: HistoryRecord
  • The history record associated with this instance object.
  • reference
  • Type: bool
  • True if the object is from a reference file. Reference objects do not persist in archives.
Returns:
Type: Guid
A unique identifier for the object if successful. Guid.Empty it not successful.
Available since:
6.24

Description:

Adds an instance object to the document.

Syntax:
public Guid AddInstanceObject(
int instanceDefinitionIndex,
Transform instanceXform,
ObjectAttributes attributes
)
Parameters:
  • instanceDefinitionIndex
  • Type: int
  • The index of the instance definition.
  • instanceXform
  • Type: Transform
  • The instance transformation.
Returns:
Type: Guid
A unique identifier for the object if successful. Guid.Empty it not successful.
Available since:
5.0

Description:

Adds an instance object to the document.

Syntax:
public Guid AddInstanceObject(
int instanceDefinitionIndex,
Transform instanceXform
)
Parameters:
  • instanceDefinitionIndex
  • Type: int
  • The index of the instance definition.
  • instanceXform
  • Type: Transform
  • The instance transformation.
Returns:
Type: Guid
A unique identifier for the object if successful. Guid.Empty it not successful.
Available since:
5.0

AddInstanceObject method

Class:  Rhino.DocObjects.Tables.ObjectTable

Nothing found