Description:

Adds a text dot object to Rhino.

Syntax:
public Guid AddTextDot(
string text,
Point3d location,
ObjectAttributes attributes
)
Parameters:
  • text
  • Type: string
  • A text string.
  • location
  • Type: Point3d
  • A point position.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds a text dot object to Rhino.

Syntax:
public Guid AddTextDot(
string text,
Point3d location
)
Parameters:
  • text
  • Type: string
  • A text string.
  • location
  • Type: Point3d
  • A point position.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:
Syntax:
public Guid AddTextDot(
TextDot dot,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds a text dot object to Rhino.

Syntax:
public Guid AddTextDot(
TextDot dot,
ObjectAttributes attributes
)
Parameters:
  • dot
  • Type: TextDot
  • A text dot that will be copied.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds a text dot object to Rhino.

Syntax:
public Guid AddTextDot(
TextDot dot
)
Parameters:
  • dot
  • Type: TextDot
  • A text dot that will be copied.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Nothing found