Description:
Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
ObjectAttributes attributes
)
Parameters:
  • plane
  • Type: Plane
  • Plane of text.
  • height
  • Type: double
  • Height of text.
  • fontName
  • Type: string
  • Name of FontFace.
  • bold
  • Type: bool
  • Bold flag.
  • italic
  • Type: bool
  • Italic flag.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:
Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
TextJustification justification,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:
Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
TextJustification justification,
ObjectAttributes attributes
)
Returns:
Type: Guid
Available since:
5.0

Description:
Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
TextJustification justification
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic
)
Parameters:
  • plane
  • Type: Plane
  • Plane of text.
  • height
  • Type: double
  • Height of text.
  • fontName
  • Type: string
  • Name of FontFace.
  • bold
  • Type: bool
  • Bold flag.
  • italic
  • Type: bool
  • Italic flag.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
Text3d text3d,
ObjectAttributes attributes
)
Parameters:
  • text3d
  • Type: Text3d
  • The text object to add.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
Text3d text3d
)
Parameters:
  • text3d
  • Type: Text3d
  • The text object to add.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds a text object to the document.

Syntax:
public Guid AddText(
TextEntity text,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • reference
  • Type: bool
  • If reference, then object will not be saved into the 3dm file.
Returns:
Type: Guid
The Id of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds a text object to the document.

Syntax:
public Guid AddText(
TextEntity text,
ObjectAttributes attributes
)
Parameters:
Returns:
Type: Guid
The Id of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds a v6_TextObject to the document.

Syntax:
public Guid AddText(
TextEntity text
)
Parameters:
Returns:
Type: Guid
The Id of the newly added object or Guid.Empty on failure.
Available since:
5.0

Nothing found