Description:

Duplicates the object that is referenced by objref. Same as Transform(objref, Transform.Identity, false)

Syntax:
public Guid Duplicate(
ObjRef objref
)
Parameters:
  • objref
  • Type: ObjRef
  • A Rhino object reference to follow for object duplication.
Returns:
Type: Guid
The new object ID.
Available since:
5.0

Description:

Duplicates the object that is referenced by obj. Same as TransformObject(obj, Transform.Identityy, false)

Syntax:
public Guid Duplicate(
RhinoObject obj
)
Parameters:
Returns:
Type: Guid
The new object ID.
Available since:
5.0

Description:

Same as TransformObject(objref, ON_Xform.Identity, false)

Syntax:
public Guid Duplicate(
Guid objectId
)
Parameters:
  • objectId
  • Type: System.Guid
  • An ID to an object in the document that needs to be duplicated.
Returns:
Type: Guid
The new object ID.
Available since:
5.0

Nothing found