Description:
Adds a rectangle to the object table.
Syntax:
public Guid AddRectangle(
Rectangle3d rectangle,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Rectangle3d rectangle,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
- rectangle
- Type: Rectangle3d
- The rectangle.
- attributes
- Type: ObjectAttributes
- Attributes that will be linked with the surface object.
- history
- Type: HistoryRecord
- History data records.
- reference
- Type: bool
- If a reference, object will not be saved in the document.
Returns:
Type: Guid
The ID.
Available since:
6.0
Description:
Adds a rectangle to the object table.
Syntax:
Parameters:
- rectangle
- Type: Rectangle3d
- The rectangle.
- attributes
- Type: ObjectAttributes
- Attributes that will be linked with the surface object.
Returns:
Type: Guid
The ID.
Available since:
6.0
Description:
Adds a rectangle to the object table.
Syntax: