Description:

Removes object from document and deletes the pointer. Typically you will want to call Delete instead in order to keep the object on the undo list.

Syntax:
public bool Purge(
RhinoObject rhinoObject
)
Parameters:
  • rhinoObject
  • Type: RhinoObject
  • A Rhino object that will be deleted.
Returns:
Type: bool
True if the object was purged; otherwise false.
Available since:
5.0

Description:

Removes object from document and deletes the pointer. Typically you will want to call Delete instead in order to keep the object on the undo list.

Syntax:
public bool Purge(
uint runtimeSerialNumber
)
Parameters:
  • runtimeSerialNumber
  • Type: uint
  • A runtime serial number of the object that will be deleted.
Returns:
Type: bool
True if the object was purged; otherwise false.
Available since:
5.0

Nothing found