Description:

Adds a mesh object to Rhino.

Syntax:
public Guid AddMesh(
Mesh mesh
)
Parameters:
  • mesh
  • Type: Geometry.Mesh
  • A duplicate of this mesh is added to Rhino.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:
Syntax:
public Guid AddMesh(
Mesh mesh,
ObjectAttributes attributes,
HistoryRecord history,
bool reference,
bool requireValidMesh
)
Returns:
Type: Guid
Available since:
6.0

Description:
Syntax:
public Guid AddMesh(
Mesh mesh,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds a mesh object to Rhino.

Syntax:
public Guid AddMesh(
Mesh mesh,
ObjectAttributes attributes
)
Parameters:
  • mesh
  • Type: Mesh
  • A duplicate of this mesh is added to Rhino.
  • attributes
  • Type: ObjectAttributes
  • Attributes that will be linked with the mesh object.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Nothing found