Description:

Deletes a collection of objects from the document.

Syntax:
public int Delete(
IEnumerable<Guid> objectIds,
bool quiet
)
Parameters:
  • objectIds
  • Type: IEnumerable<Guid>
  • Ids of all objects to delete.
  • quiet
  • Type: bool
  • If false, a message box will appear when an object cannot be deleted.
Returns:
Type: int
The number of successfully deleted objects.
Available since:
5.0

Description:

Deletes objref.Object(). The deletion can be undone by calling UndeleteObject().

Syntax:
public bool Delete(
ObjRef objref,
bool quiet,
bool ignoreModes
)
Parameters:
  • objref
  • Type: ObjRef
  • objref.Object() will be deleted.
  • quiet
  • Type: bool
  • If false, a message box will appear when an object cannot be deleted.
  • ignoreModes
  • Type: bool
  • If true, locked and hidden objects are deleted. If False objects that are locked, hidden, or on locked or hidden layers are not deleted.
Returns:
Type: bool
True on success, False on failure.
Available since:
6.0

Description:

Deletes objref.Object(). The deletion can be undone by calling UndeleteObject().

Syntax:
public bool Delete(
ObjRef objref,
bool quiet
)
Parameters:
  • objref
  • Type: ObjRef
  • objref.Object() will be deleted.
  • quiet
  • Type: bool
  • If false, a message box will appear when an object cannot be deleted.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Deletes an object, taking into account modes and not showing error message boxes.

Syntax:
public override bool Delete(
RhinoObject item
)
Parameters:
Returns:
Type: bool
True on success.
Available since:
6.0

Description:

Deletes object from document. The deletion can be undone by calling UndeleteObject().

Syntax:
public bool Delete(
RhinoObject obj,
bool quiet,
bool ignoreModes
)
Parameters:
  • quiet
  • Type: bool
  • If false, a message box will appear when an object cannot be deleted.
  • ignoreModes
  • Type: bool
  • If true, locked and hidden objects are deleted. If False objects that are locked, hidden, or on locked or hidden layers are not deleted.
Returns:
Type: bool
True on success, False on failure.
Available since:
6.0

Description:

Deletes object from document. The deletion can be undone by calling UndeleteObject().

Syntax:
public bool Delete(
RhinoObject obj,
bool quiet
)
Parameters:
  • quiet
  • Type: bool
  • If false, a message box will appear when an object cannot be deleted.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Deletes object from document. The deletion can be undone by calling UndeleteObject().

Syntax:
public bool Delete(
Guid objectId,
bool quiet
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of the object to delete.
  • quiet
  • Type: bool
  • If false, a message box will appear when an object cannot be deleted.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Nothing found