Description:

Finds objects bounded by a polyline region

Syntax:
public RhinoObject[] FindByWindowRegion(
RhinoViewport viewport,
IEnumerable<Point3d> region,
bool inside,
ObjectType filter
)
Parameters:
  • region
  • Type: IEnumerable<Point3d>
  • list of points that define the
  • inside
  • Type: bool
  • should objects returned be the ones inside of this region (or outside)
  • filter
  • Type: ObjectType
  • filter down list by object type
Returns:
An array of RhinoObjects that are inside of this region
Available since:
5.7

Description:

Finds objects bounded by a polyline region

Syntax:
public RhinoObject[] FindByWindowRegion(
RhinoViewport viewport,
Point2d screen1,
Point2d screen2,
bool inside,
ObjectType filter
)
Parameters:
  • screen1
  • Type: Point2d
  • first screen corner
  • screen2
  • Type: Point2d
  • second screen corner
  • inside
  • Type: bool
  • should objects returned be the ones inside of this region (or outside)
  • filter
  • Type: ObjectType
  • filter down list by object type
Returns:
An array of RhinoObjects that are inside of this region
Available since:
5.8

FindByWindowRegion method

Class:  Rhino.DocObjects.Tables.ObjectTable

Nothing found