Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
ObjRef objref,
Arc arc
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • arc
  • Type: Arc
  • new arc to be added. The arc is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:
Syntax:
public bool Replace(
ObjRef objref,
Brep brep,
bool splitKinkySurfaces
)
Returns:
Type: bool
Available since:
6.1

Description:

Replaces one object with new brep object.

Syntax:
public bool Replace(
ObjRef objref,
Brep brep
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • brep
  • Type: Brep
  • new brep to be added A duplicate of the brep is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
ObjRef objref,
Circle circle
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • circle
  • Type: Circle
  • new circle to be added. The circle is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
ObjRef objref,
Curve curve
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • curve
  • Type: Curve
  • New curve to be added. A duplicate of the curve is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new extrusion object.

Syntax:
public bool Replace(
ObjRef objref,
Extrusion extrusion
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • extrusion
  • Type: Extrusion
  • New extrusion to be added. A duplicate of the extrusion is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
6.0

Description:

Replaces the geometry in one object.

Syntax:
public bool Replace(
ObjRef objref,
GeometryBase geometry,
bool ignoreModes
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • ignoreModes
  • Type: bool
Returns:
Type: bool
True if successful.
Available since:
7.9

Description:

Replaces one object with new hatch object.

Syntax:
public bool Replace(
ObjRef objref,
Hatch hatch
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • hatch
  • Type: Hatch
  • new hatch to be added. The hatch is copied.
Returns:
Type: bool
True if successful.
Available since:
6.1

Description:

Replaces one object with new text object.

Syntax:
public bool Replace(
ObjRef objref,
Leader leader
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • leader
  • Type: Leader
  • new leader to be added. The leader is copied.
Returns:
Type: bool
True if successful.
Available since:
6.0

Description:

Replaces one object with new line curve object.

Syntax:
public bool Replace(
ObjRef objref,
Line line
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • line
  • Type: Line
  • new line to be added. The line is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new mesh object.

Syntax:
public bool Replace(
ObjRef objref,
Mesh mesh
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • mesh
  • Type: Mesh
  • new mesh to be added A duplicate of the mesh is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new point object.

Syntax:
public bool Replace(
ObjRef objref,
Point point
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • point
  • Type: Point
  • new point to be added. The point is copied.
Returns:
Type: bool
True if successful.
Available since:
6.0

Description:

Replaces one object with new point object.

Syntax:
public bool Replace(
ObjRef objref,
Point3d point
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • point
  • Type: Point3d
  • new point to be added. The point is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new point cloud object.

Syntax:
public bool Replace(
ObjRef objref,
PointCloud pointcloud
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • pointcloud
  • Type: PointCloud
  • new point cloud to be added A duplicate of the point cloud is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
ObjRef objref,
Polyline polyline
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • polyline
  • Type: Polyline
  • new polyline to be added. The polyline is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with another. Conceptually, this function is the same as calling Setting new_object attributes = old_object attributes DeleteObject(old_object); AddObject(old_object);

Syntax:
public bool Replace(
ObjRef objref,
RhinoObject newObject
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • newObject
  • Type: RhinoObject
  • new replacement object - must not be in document.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with a new SubD object.

Syntax:
public bool Replace(
ObjRef objref,
SubD subD
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • subD
  • Type: SubD
  • new SubD to be added A duplicate of the SubD is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
7.0

Description:

Replaces one object with new surface object.

Syntax:
public bool Replace(
ObjRef objref,
Surface surface
)
Parameters:
  • objref
  • Type: ObjRef
  • reference to old object to be replaced. The objref.Object() will be deleted.
  • surface
  • Type: Surface
  • new surface to be added A duplicate of the surface is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new text dot object.

Syntax:
public bool Replace(
ObjRef objref,
TextDot dot
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • dot
  • Type: TextDot
  • new text dot to be added. The text dot is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new text object.

Syntax:
public bool Replace(
ObjRef objref,
TextEntity text
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to old object to be replaced. The object objref.Object() will be deleted.
  • text
  • Type: TextEntity
  • new text to be added. The text is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
Guid objectId,
Arc arc
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • arc
  • Type: Arc
  • new arc to be added. The arc is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:
Syntax:
public bool Replace(
Guid objectId,
Brep brep,
bool splitKinkySurfaces
)
Returns:
Type: bool
Available since:
6.1

Description:

Replaces one object with new brep object.

Syntax:
public bool Replace(
Guid objectId,
Brep brep
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • brep
  • Type: Brep
  • new surface to be added A duplicate of the brep is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
Guid objectId,
Circle circle
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • circle
  • Type: Circle
  • new circle to be added. The circle is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
Guid objectId,
Curve curve
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • curve
  • Type: Curve
  • New curve to be added. A duplicate of the curve is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new extrusion object.

Syntax:
public bool Replace(
Guid objectId,
Extrusion extrusion
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • extrusion
  • Type: Extrusion
  • New extrusion to be added. A duplicate of the extrusion is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
6.0

Description:

Replaces the geometry in one object.

Syntax:
public bool Replace(
Guid objectId,
GeometryBase geometry,
bool ignoreModes
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • ignoreModes
  • Type: bool
Returns:
Type: bool
True if successful.
Available since:
7.9

Description:

Replaces one object with new hatch object.

Syntax:
public bool Replace(
Guid objectId,
Hatch hatch
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • hatch
  • Type: Hatch
  • new hatch to be added. The hatch is copied.
Returns:
Type: bool
True if successful.
Available since:
6.1

Description:

Replaces one object with new text object.

Syntax:
public bool Replace(
Guid objectId,
Leader leader
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • leader
  • Type: Leader
  • new leader to be added. The leader is copied.
Returns:
Type: bool
True if successful.
Available since:
6.0

Description:

Replaces one object with new line curve object.

Syntax:
public bool Replace(
Guid objectId,
Line line
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • line
  • Type: Line
  • new line to be added. The line is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new mesh object.

Syntax:
public bool Replace(
Guid objectId,
Mesh mesh
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • mesh
  • Type: Mesh
  • new mesh to be added A duplicate of the mesh is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new point object.

Syntax:
public bool Replace(
Guid objectId,
Point point
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • point
  • Type: Point
  • new point to be added. The point is copied.
Returns:
Type: bool
True if successful.
Available since:
6.0

Description:

Replaces one object with new point object.

Syntax:
public bool Replace(
Guid objectId,
Point3d point
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • point
  • Type: Point3d
  • new point to be added. The point is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new point cloud object.

Syntax:
public bool Replace(
Guid objectId,
PointCloud pointcloud
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • pointcloud
  • Type: PointCloud
  • new point cloud to be added A duplicate of the point cloud is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new curve object.

Syntax:
public bool Replace(
Guid objectId,
Polyline polyline
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • polyline
  • Type: Polyline
  • new polyline to be added. The polyline is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new subd object.

Syntax:
public bool Replace(
Guid objectId,
SubD subD
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • subD
  • Type: SubD
  • new mesh to be added A duplicate of the mesh is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
7.0

Description:

Replaces one object with new surface object.

Syntax:
public bool Replace(
Guid objectId,
Surface surface
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • surface
  • Type: Surface
  • new surface to be added A duplicate of the surface is added to the Rhino model.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new text dot object.

Syntax:
public bool Replace(
Guid objectId,
TextDot dot
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • dot
  • Type: TextDot
  • new text dot to be added. The text dot is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Description:

Replaces one object with new text object.

Syntax:
public bool Replace(
Guid objectId,
TextEntity text
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to be replaced.
  • text
  • Type: TextEntity
  • new text to be added. The text is copied.
Returns:
Type: bool
True if successful.
Available since:
5.0

Nothing found