Description:

Adds a point cloud object to the document.

Syntax:
public Guid AddOrderedPointCloud(
int xCt,
int yCt,
int zCt,
Point3d min,
Point3d max,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • xCt
  • Type: int
  • Number of points in X dir.
  • yCt
  • Type: int
  • Number of points in Y dir.
  • zCt
  • Type: int
  • Number of points in Z dir.
  • min
  • Type: Point3d
  • point at x0,y0,z0 of bounding box of the pointcloud
  • max
  • Type: Point3d
  • point at x1,y1,z1 of bounding box of the pointcloud
  • attributes
  • Type: ObjectAttributes
  • Attributes to apply to point cloud. None is acceptable
  • history
  • Type: HistoryRecord
  • history associated with this point cloud. None is acceptable
  • reference
  • Type: bool
  • True if the object is from a reference file. Reference objects do not persist in archives
Returns:
Type: Guid
A unique identifier for the object.
Available since:
8.0

AddOrderedPointCloud method

Class:  Rhino.DocObjects.Tables.ObjectTable

Nothing found