Description:
Adds a radial dimension object to the document.
Syntax:
public Guid AddRadialDimension(
RadialDimension dimension,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
RadialDimension dimension,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
- dimension
- Type: RadialDimension
- Dimension object to add.
- attributes
- Type: ObjectAttributes
- Attributes to apply to dimension.
- history
- Type: HistoryRecord
- Object history to save.
- reference
- Type: bool
- If reference, then object will not be saved into the 3dm file.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0
Description:
Syntax:
Returns:
Type: Guid
Available since:
5.0
Description:
Syntax:
Returns:
Type: Guid
Available since:
5.0