Description:

Modifies an object's render material assignment, this will set the objects material source to ObjectMaterialSource.MaterialFromObject.

Syntax:
public bool ModifyRenderMaterial(
ObjRef objRef,
RenderMaterial material
)
Parameters:
  • objRef
  • Type: ObjRef
  • Object to modify.
Returns:
Type: bool
Returns True on success otherwise returns false.
Available since:
5.7

Description:

Modifies an object's render material assignment, this will set the objects material source to ObjectMaterialSource.MaterialFromObject.

Syntax:
public bool ModifyRenderMaterial(
RhinoObject obj,
RenderMaterial material
)
Parameters:
Returns:
Type: bool
Returns True on success otherwise returns false.
Available since:
5.7

Description:

Modifies an object's render material assignment, this will set the objects material source to ObjectMaterialSource.MaterialFromObject.

Syntax:
public bool ModifyRenderMaterial(
Guid objectId,
RenderMaterial material
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to modify.
Returns:
Type: bool
Returns True on success otherwise returns false.
Available since:
5.7

ModifyRenderMaterial method

Class:  Rhino.DocObjects.Tables.ObjectTable

Nothing found