Description:

Replaces the underlying instance definition of an instance object.

Syntax:
public bool ReplaceInstanceObject(
ObjRef objref,
int instanceDefinitionIndex
)
Parameters:
  • objref
  • Type: ObjRef
  • Reference to the instance object to be replaced. The objref.Object() will be deleted.
  • instanceDefinitionIndex
  • Type: int
  • The index of the new instance definition to use.
Returns:
Type: bool
True if successful.
Available since:
6.8

Description:

Replaces the underlying instance definition of an instance object.

Syntax:
public bool ReplaceInstanceObject(
Guid objectId,
int instanceDefinitionIndex
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of the instance object to be replaced.
  • instanceDefinitionIndex
  • Type: int
  • The index of the new instance definition to use.
Returns:
Type: bool
True if successful.
Available since:
6.8

ReplaceInstanceObject method

Class:  Rhino.DocObjects.Tables.ObjectTable

Nothing found