Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Line line,
ObjectAttributes attributes
)
Parameters:
  • line
  • Type: Line
  • The line value.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Line line
)
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:
Syntax:
public Guid AddLine(
Point3d from,
Point3d to,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Returns:
Type: Guid
Available since:
5.0

Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Point3d from,
Point3d to,
ObjectAttributes attributes
)
Parameters:
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Point3d from,
Point3d to
)
Parameters:
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Nothing found