Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
double x,
double y,
double z
)
Parameters:
  • x
  • Type: double
  • X component of point coordinate.
  • y
  • Type: double
  • Y component of point coordinate.
  • z
  • Type: double
  • Z component of point coordinate.
Returns:
Type: Guid
A unique identifier for the object..
Available since:
5.0

Description:

Adds a point object and its geometry-linked information to the document

Syntax:
public Guid AddPoint(
Point point,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • point
  • Type: Point
  • A point geometry class.
  • attributes
  • Type: ObjectAttributes
  • attributes to apply to point. None is acceptable
  • history
  • Type: HistoryRecord
  • history associated with this point. None is acceptable
  • reference
  • Type: bool
  • True if the object is from a reference file. Reference objects do not persist in archives
Returns:
Type: Guid
A unique identifier for the object.
Available since:
6.0

Description:

Adds a point object to the document

Syntax:
public Guid AddPoint(
Point3d point,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
  • point
  • Type: Point3d
  • location of point
  • attributes
  • Type: ObjectAttributes
  • attributes to apply to point. None is acceptable
  • history
  • Type: HistoryRecord
  • history associated with this point. None is acceptable
  • reference
  • Type: bool
  • True if the object is from a reference file. Reference objects do not persist in archives
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
Point3d point,
ObjectAttributes attributes
)
Parameters:
  • point
  • Type: Point3d
  • location of point.
  • attributes
  • Type: ObjectAttributes
  • attributes to apply to point. None is acceptable
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
Point3d point
)
Parameters:
  • point
  • Type: Point3d
  • location of point.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
Point3f point,
ObjectAttributes attributes
)
Parameters:
  • point
  • Type: Point3f
  • location of point.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
Point3f point
)
Parameters:
  • point
  • Type: Point3f
  • location of point.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Nothing found