Description:

Deletes one or more grip objects.

Syntax:
public int DeleteGrips(
IEnumerable<GripObject> grips
)
Parameters:
  • grips
  • Type: IEnumerable<GripObject>
  • The grip objects to delete.
Returns:
Type: int
The number of successfully deleted grip objects.
Available since:
6.5

Description:

Deletes one or more grip objects.

Syntax:
public int DeleteGrips(
IEnumerable<Guid> gripIds
)
Parameters:
  • gripIds
  • Type: IEnumerable<Guid>
  • The ids of the grip objects to delete.
Returns:
Type: int
The number of successfully deleted grip objects.
Available since:
6.5

Description:

Deletes one or more grip objects.

Syntax:
public int DeleteGrips(
IEnumerable<ObjRef> gripRefs
)
Parameters:
  • gripRefs
  • Type: IEnumerable<ObjRef>
  • References to the grip objects to delete.
Returns:
Type: int
The number of successfully deleted grip objects.
Available since:
6.5

Description:

Deletes one or more grip objects.

Syntax:
public int DeleteGrips(
RhinoObject owner,
IEnumerable<int> gripIndices
)
Parameters:
  • gripIndices
  • Type: IEnumerable<int>
  • The indices of the grip objects to delete.
Returns:
Type: int
The number of successfully deleted grip objects.
Available since:
6.5

Nothing found