Description:
Adds an angular dimension object to the document.
Syntax:
public Guid AddAngularDimension(
AngularDimension dimension,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
AngularDimension dimension,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
- dimension
- Type: AngularDimension
- Dimension object to add.
- attributes
- Type: ObjectAttributes
- Attributes to apply to dimension.
- history
- Type: HistoryRecord
- Object history to save.
- reference
- Type: bool
- If reference, then object will not be saved into the 3dm file.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0
Description:
Adds a angular dimension object to the document.
Syntax:
Parameters:
- dimension
- Type: AngularDimension
- Dimension object to add.
- attributes
- Type: ObjectAttributes
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0
Description:
Adds a angular dimension object to the document.
Syntax:
Parameters:
- dimension
- Type: AngularDimension
- Dimension object to add.
Returns:
Type: Guid
The Id of the newly added object or Guid.Empty on failure.
Available since:
5.0