Description:
Adds a point cloud object to the document.
Syntax:
public Guid AddPointCloud(
IEnumerable<Point3d> points,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
IEnumerable<Point3d> points,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
- points
- Type: IEnumerable<Point3d>
- A list, an array or any enumerable set of points
- attributes
- Type: ObjectAttributes
- Attributes to apply to point cloud. None is acceptable
- history
- Type: HistoryRecord
- history associated with this point cloud. None is acceptable
- reference
- Type: bool
- True if the object is from a reference file. Reference objects do not persist in archives
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0
Description:
Adds a point cloud object to the document.
Syntax:
Parameters:
- points
- Type: IEnumerable<Point3d>
- A list, an array or any enumerable set of points.
- attributes
- Type: ObjectAttributes
- attributes to apply to point cloud.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0
Description:
Adds a point cloud object to the document.
Syntax:
public Guid AddPointCloud(
IEnumerable<Point3d> points
)
IEnumerable<Point3d> points
)
Parameters:
- points
- Type: IEnumerable<Point3d>
- A list, an array or any enumerable set of points.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0
Description:
Adds a point cloud object to the document.
Syntax:
public Guid AddPointCloud(
PointCloud cloud,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
PointCloud cloud,
ObjectAttributes attributes,
HistoryRecord history,
bool reference
)
Parameters:
- cloud
- Type: PointCloud
- PointCloud to add.
- attributes
- Type: ObjectAttributes
- Attributes to apply to point cloud. None is acceptable
- history
- Type: HistoryRecord
- history associated with this point cloud. None is acceptable
- reference
- Type: bool
- True if the object is from a reference file. Reference objects do not persist in archives
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0
Description:
Adds a point cloud object to the document.
Syntax:
Parameters:
- cloud
- Type: PointCloud
- PointCloud to add.
- attributes
- Type: ObjectAttributes
- Attributes to apply to point cloud.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0
Description:
Adds a point cloud object to the document.
Syntax:
Parameters:
- cloud
- Type: PointCloud
- PointCloud to add.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0