Description:

Selects or deselects a collection of objects.

Syntax:
public int Select(
IEnumerable<Guid> objectIds,
bool select
)
Parameters:
  • objectIds
  • Type: IEnumerable<Guid>
  • Ids of objects to select or deselect.
  • select
  • Type: bool
  • If true, objects will be selected. If false, objects will be deselected.
Returns:
Type: int
Number of objects successfully selected or deselected.
Available since:
5.0

Description:

Selects a collection of objects.

Syntax:
public int Select(
IEnumerable<Guid> objectIds
)
Parameters:
  • objectIds
  • Type: IEnumerable<Guid>
  • Ids of objects to select.
Returns:
Type: int
Number of objects successfully selected.
Available since:
5.0

Description:

Selects or deselects a collection of objects.

Syntax:
public int Select(
IEnumerable<ObjRef> objRefs,
bool select
)
Parameters:
  • objRefs
  • Type: IEnumerable<ObjRef>
  • References to objects to select or deselect.
  • select
  • Type: bool
  • If true, objects will be selected. If false, objects will be deselected.
Returns:
Type: int
Number of objects successfully selected or deselected.
Available since:
5.0

Description:

Selects a collection of objects.

Syntax:
public int Select(
IEnumerable<ObjRef> objRefs
)
Parameters:
  • objRefs
  • Type: IEnumerable<ObjRef>
  • References to objects to select.
Returns:
Type: int
Number of objects successfully selected.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
ObjRef objref,
bool select,
bool syncHighlight,
bool persistentSelect,
bool ignoreGripsState,
bool ignoreLayerLocking,
bool ignoreLayerVisibility
)
Parameters:
  • objref
  • Type: ObjRef
  • Object represented by this ObjRef is selected.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
  • syncHighlight
  • Type: bool
  • If true, then the object is highlighted if it is selected and unhighlighted if is not selected.
  • persistentSelect
  • Type: bool
  • Objects that are persistently selected stay selected when a command terminates.
  • ignoreGripsState
  • Type: bool
  • If true, then objects with grips on can be selected. If false, then the value returned by the object's IsSelectableWithGripsOn() function decides if the object can be selected when it has grips turned on.
  • ignoreLayerLocking
  • Type: bool
  • If true, then objects on locked layers can be selected.
  • ignoreLayerVisibility
  • Type: bool
  • If true, then objects on hidden layers can be selectable.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
ObjRef objref,
bool select,
bool syncHighlight,
bool persistentSelect
)
Parameters:
  • objref
  • Type: ObjRef
  • Object represented by this ObjRef is selected.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
  • syncHighlight
  • Type: bool
  • If true, then the object is highlighted if it is selected and unhighlighted if is not selected.
  • persistentSelect
  • Type: bool
  • Objects that are persistently selected stay selected when a command terminates.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
ObjRef objref,
bool select,
bool syncHighlight
)
Parameters:
  • objref
  • Type: ObjRef
  • Object represented by this ObjRef is selected.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
  • syncHighlight
  • Type: bool
  • If true, then the object is highlighted if it is selected and unhighlighted if is not selected.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
ObjRef objref,
bool select
)
Parameters:
  • objref
  • Type: ObjRef
  • Object represented by this ObjRef is selected.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select a single object.

Syntax:
public bool Select(
ObjRef objref
)
Parameters:
  • objref
  • Type: ObjRef
  • Object represented by this ObjRef is selected.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
Guid objectId,
bool select,
bool syncHighlight,
bool persistentSelect,
bool ignoreGripsState,
bool ignoreLayerLocking,
bool ignoreLayerVisibility
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to select.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
  • syncHighlight
  • Type: bool
  • If true, then the object is highlighted if it is selected and unhighlighted if is not selected.
  • persistentSelect
  • Type: bool
  • Objects that are persistently selected stay selected when a command terminates.
  • ignoreGripsState
  • Type: bool
  • If true, then objects with grips on can be selected. If false, then the value returned by the object's IsSelectableWithGripsOn() function decides if the object can be selected when it has grips turned on.
  • ignoreLayerLocking
  • Type: bool
  • If true, then objects on locked layers can be selected.
  • ignoreLayerVisibility
  • Type: bool
  • If true, then objects on hidden layers can be selectable.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
Guid objectId,
bool select,
bool syncHighlight,
bool persistentSelect
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to select.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
  • syncHighlight
  • Type: bool
  • If true, then the object is highlighted if it is selected and unhighlighted if is not selected.
  • persistentSelect
  • Type: bool
  • Objects that are persistently selected stay selected when a command terminates.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
Guid objectId,
bool select,
bool syncHighlight
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to select.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
  • syncHighlight
  • Type: bool
  • If true, then the object is highlighted if it is selected and unhighlighted if is not selected.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select or deselects a single object.

Syntax:
public bool Select(
Guid objectId,
bool select
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to select.
  • select
  • Type: bool
  • If true, the object will be selected, if false, it will be deselected.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Select a single object.

Syntax:
public bool Select(
Guid objectId
)
Parameters:
  • objectId
  • Type: System.Guid
  • Id of object to select.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Nothing found