Description:

Gets isoparametric curve.

Syntax:
public Curve IsoCurve(
int direction,
double constantParameter
)
Parameters:
  • direction
  • Type: int
  • 0 first parameter varies and second parameter is constant e.g., point on IsoCurve(0,c) at t is srf(t,c) This is a horizontal line from left to right 1 first parameter is constant and second parameter varies e.g., point on IsoCurve(1,c) at t is srf(c,t This is a vertical line from bottom to top.
  • constantParameter
  • Type: double
  • The parameter that was constant on the original surface.
Returns:
Type: Curve
An isoparametric curve or None on error.
Remarks:
In this function "direction" indicates which direction the resulting curve runs. 0: horizontal, 1: vertical In the other Surface functions that take a "direction" argument, "direction" indicates if "constantParameter" is a "u" or "v" parameter.
Available since:
5.0

Nothing found