Description:
Rebuilds an existing surface with a new surface to a given point count in either the u or v directions independently.
Syntax:
public NurbsSurface RebuildOneDirection(
int direction,
int pointCount,
LoftType loftType,
double refitTolerance
)
int direction,
int pointCount,
LoftType loftType,
double refitTolerance
)
Parameters:
- direction
- Type: int
- The direction (0 = U, 1 = V).
- pointCount
- Type: int
- The number of points in the output surface in the "direction" direction.
- loftType
- Type: LoftType
- The loft type
- refitTolerance
- Type: double
- The refit tolerance. When in doubt, use the document's model absolute tolerance.
Returns:
Type: NurbsSurface
new rebuilt surface on success. None on failure.
Available since:
6.7