Description:

Tests a surface to see if it is a portion of a cone and returns the cone.

Syntax:
public bool TryGetCone(
out Cone cone,
double tolerance
)
Parameters:
  • cone
  • Type: Cone
  • On success, the cone parameters are filled in.
  • tolerance
  • Type: double
  • tolerance to use when checking.
Returns:
Type: bool
True if the surface is a portion of a cone.
Available since:
5.0

Description:

Tests a surface to see if it is a portion of a cone within RhinoMath.ZeroTolerance and return the cone.

Syntax:
public bool TryGetCone(
out Cone cone
)
Parameters:
  • cone
  • Type: Cone
  • On success, the cone parameters are filled in.
Returns:
Type: bool
True if the surface is a portion of a cone.
Available since:
5.0

TryGetCone method

Class:  Rhino.Geometry.Surface

Nothing found