Description:

Test a surface to see if it is a portion of a sphere and return the sphere.

Syntax:
public bool TryGetSphere(
out Sphere sphere,
double tolerance
)
Parameters:
  • sphere
  • Type: Sphere
  • On success, the sphere parameters are filled in.
  • tolerance
  • Type: double
  • tolerance to use when checking.
Returns:
Type: bool
True if the surface is a portion of a sphere.
Available since:
5.0

Description:

Test a surface to see if it is a portion of a sphere and return the sphere.

Syntax:
public bool TryGetSphere(
out Sphere sphere
)
Parameters:
  • sphere
  • Type: Sphere
  • On success, the sphere parameters are filled in.
Returns:
Type: bool
True if the surface is a portion of a sphere.
Available since:
5.0

TryGetSphere method

Class:  Rhino.Geometry.Surface

Nothing found