Description:

Find parameters of the point on a surface that is locally closest to the testPoint. The search for a local close point starts at seed parameters.

Syntax:
public bool LocalClosestPoint(
Point3d testPoint,
double seedU,
double seedV,
out double u,
out double v
)
Parameters:
  • testPoint
  • Type: Point3d
  • A point to test against.
  • seedU
  • Type: double
  • The seed parameter in the U direction.
  • seedV
  • Type: double
  • The seed parameter in the V direction.
  • u
  • Type: double
  • U parameter of the surface that is closest to testPoint.
  • v
  • Type: double
  • V parameter of the surface that is closest to testPoint.
Returns:
Type: bool
True if the search is successful, False if the search fails.
Available since:
6.3

/
/
/
LocalClosestPoint

LocalClosestPoint method

Class:  Rhino.Geometry.Surface

Nothing found