Description:

Creates a soft edited surface from an existing surface using a smooth field of influence.

Syntax:
public static Surface CreateSoftEditSurface(
Surface surface,
Point2d uv,
Vector3d delta,
double uLength,
double vLength,
double tolerance,
bool fixEnds
)
Parameters:
  • surface
  • Type: Surface
  • The surface to soft edit.
  • uv
  • Type: Point2d
  • A point in the parameter space to move from. This location on the surface is moved, and the move is smoothly tapered off with increasing distance along the surface from this parameter.
  • delta
  • Type: Vector3d
  • The direction and magnitude, or maximum distance, of the move.
  • uLength
  • Type: double
  • The distance along the surface's u-direction from the editing point over which the strength of the editing falls off smoothly.
  • vLength
  • Type: double
  • The distance along the surface's v-direction from the editing point over which the strength of the editing falls off smoothly.
  • tolerance
  • Type: double
  • The active document's model absolute tolerance.
  • fixEnds
  • Type: bool
  • Keeps edge locations fixed.
Returns:
Type: Surface
The soft edited surface if successful. None on failure.
Available since:
6.0

/
/
/
CreateSoftEditSurface

CreateSoftEditSurface method

Class:  Rhino.Geometry.Surface

Nothing found