Description:

Determines if a 2d bounding box is isoparametric in the parameter space of this surface.

Syntax:
public IsoStatus IsIsoparametric(
BoundingBox bbox
)
Parameters:
Returns:
Type: IsoStatus
IsoStatus flag describing the iso-parametric relationship between the surface and the bounding box.
Available since:
5.0

Description:

Determines if a 2D curve is isoparametric in the parameter space of this surface.

Syntax:
public IsoStatus IsIsoparametric(
Curve curve,
Interval curveDomain
)
Parameters:
  • curve
  • Type: Curve
  • Curve to test.
  • curveDomain
  • Type: Interval
  • Sub domain of the curve.
Returns:
Type: IsoStatus
IsoStatus flag describing the iso-parametric relationship between the surface and the curve.
Available since:
5.0

Description:

Determines if a 2d curve is isoparametric in the parameter space of this surface.

Syntax:
public IsoStatus IsIsoparametric(
Curve curve
)
Parameters:
  • curve
  • Type: Curve
  • Curve to test.
Returns:
Type: IsoStatus
IsoStatus flag describing the iso-parametric relationship between the surface and the curve.
Available since:
5.0

/
/
/
IsIsoparametric

IsIsoparametric method

Class:  Rhino.Geometry.Surface

Nothing found