Description:

Evaluates a surface mathematically.

Syntax:
public bool Evaluate(
double u,
double v,
int numberDerivatives,
out Point3d point,
out Vector3d[] derivatives
)
Parameters:
  • numberDerivatives
  • Type: int
  • The number of derivatives.
  • point
  • Type: Point3d
  • A point. This out parameter will be assigned during this call.
  • derivatives
  • Type: Vector3d[]
  • A vector array. This out parameter will be assigned during this call. This can be null.
Returns:
Type: bool
True if the operation succeeded; False otherwise.
Remarks:
The partial derivatives will be in the order {Su, Sv} for numberDerivatives = 1, {Su, Sv, Suu, Suv, Svv} for 2, {Su, Sv, Suu, Suv, Svv, Suuu, Suuv, Suvv, Svvv} for 3, and similar for higher counts.
Available since:
5.0

Evaluate method

Class:  Rhino.Geometry.Surface

Nothing found