Description:
Syntax:
public Curve[] FitCurveToSurface(
Curve trimCurve3d,
Vector3d trimProjectionDir,
double tolerance,
IEnumerable<double> Knots,
bool divideIntoSections,
ref Curve trimCurveOnSurface,
ref Curve splitCurve
)
Parameters:
  • trimCurve3d
  • Type: Curve
  • curve that will trim from one edge to the opposite
  • trimProjectionDir
  • Type: Vector3d
  • Vector for projection, or zero vector for no projection
  • tolerance
  • Type: double
  • 3d tolerance for projection, splitting, fitting...
  • Knots
  • Type: IEnumerable<double>
  • For TrimParamKnots=3, the custom knots to add
  • divideIntoSections
  • Type: bool
  • If true, the surface is divided at each knot
  • trimCurveOnSurface
  • Type: Curve
  • the actual trim curve as it is projected on or pulled to the surface
  • splitCurve
  • Type: Curve
  • the actual fit curve the split the surface
Returns:
Type: Curve[]
Available since:
8.0

/
/
/
FitCurveToSurface

FitCurveToSurface method

Class:  Rhino.Geometry.Surface

Nothing found