Description:

Constructs a geodesic between 2 points, used by ShortPath command in Rhino.

Syntax:
public Curve ShortPath(
Point2d start,
Point2d end,
double tolerance
)
Parameters:
  • start
  • Type: Point2d
  • start point of curve in parameter space. Points must be distinct in the domain of the surface.
  • end
  • Type: Point2d
  • end point of curve in parameter space. Points must be distinct in the domain of the surface.
  • tolerance
  • Type: double
  • tolerance used in fitting discrete solution.
Returns:
Type: Curve
a geodesic curve on the surface on success. None on failure.
Available since:
5.0

ShortPath method

Class:  Rhino.Geometry.Surface

Nothing found